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Copyright © Siemens 2024. 
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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 
 WARNING 

indicates that death or severe personal injury may result if proper precautions are not taken. 
 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 NOTICE 

indicates that property damage can result if proper precautions are not taken. 
If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens Aktiengesellschaft. The remaining trademarks in 
this publication may be trademarks whose use by third parties for their own purposes could violate the rights of 
the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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Introduction 1 
 

LOGO! Access Tool is an add-in for Excel. It connects to LOGO! Base Module through HTTP or 
HTTPS.  

LOGO! Access Tool provides the following features: 

• Set data synchronization period 

• Show history data 

• Start or stop the data synchronization 

• Get value of LOGO! Variables such as I, Q and M 

• Record all variables values and save them in log files 

Compatibility 
• If LOGO! Access Tool connects to LOGO! Base Module through HTTP, the compatibility 

information is as follows: 

Supported Office Excel versions 

– Office Excel 2007 

– Office Excel 2010 

– Office Excel 2013 

– Office Excel 2016 

– Office Excel 2019 

– Office Excel 365 

Supported LOGO! Base Modules 

– LOGO! 8 (0BA8 Standard) 

– LOGO! 8.1 & 8.2 (LOGO! 8 FS4) 

– LOGO! 8.3 

– LOGO! 8.4 and later versions 

Supported Windows operating systems 

– Windows 7 

– Windows 8 

– Windows 10 

– Windows 11 
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• If LOGO! Access Tool connects to LOGO! Base Module through HTTPS, the compatibility 
information is as follows: 

Supported Office Excel versions 

– Office Excel 2007 

– Office Excel 2010 

– Office Excel 2013 

– Office Excel 2016 

– Office Excel 2019 

– Office Excel 365 

Supported LOGO! Base Modules 

– LOGO! 8.3 

– LOGO! 8.4 and later versions 

Supported Windows operating systems 

– Windows 8 

– Windows 10 

– Windows 11 

Document History 
The following editions of LOGO! Access Tool have been published: 
 
Edition Version Comment 
07/2016 V1.0.0 First edition 
05/2017 V1.0.1 Second edition 
11/2017 V2.0.0 Third edition 
03/2019 V2.0.1 Fourth edition 
10/2020 V2.1.0 Fifth edition 
06/2023 V2.1.1 Sixth edition 
08/2024 V2.1.1 Seventh edition 
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Security 2 
2.1 Cybersecurity information 

Siemens provides products and solutions with industrial cybersecurity functions that support 
the secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
cybersecurity concept. Siemens’ products and solutions constitute one element of such a 
concept. 

Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected 
to an enterprise network or the internet if and to the extent such a connection is necessary 
and only when appropriate security measures (e.g. firewalls and/or network segmentation) 
are in place. 

For additional information on industrial cybersecurity measures that may be implemented, 
please visit  
https://www.siemens.com/cybersecurity-industry.  

Siemens’ products and solutions undergo continuous development to make them more 
secure. Siemens strongly recommends that product updates are applied as soon as they are 
available and that the latest product versions are used. Use of product versions that are no 
longer supported, and failure to apply the latest updates may increase customer’s exposure to 
cyber threats. 

To stay informed about product updates, subscribe to the Siemens Industrial Cybersecurity 
RSS Feed under  
https://new.siemens.com/cert.  

2.2 Data protection 
Siemens observes the data protection guidelines, especially the requirements regarding data 
minimization (privacy by design). This means the following for this product: The product does 
not process / save any personal information, but only technical functional data (e.g. time 
stamps). If the user links this data to other data (e.g. shift plans) or if the user saves personal 
information on the same medium (e.g. hard disk) and therefore creates a personal reference 
in the process, the user has to ensure meeting the guidelines regarding data protection. 
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 Note 
Notes on protecting administrator accounts 

A user with administrator rights has extensive access and manipulation options available to 
the system. 
Therefore, ensure there are adequate safeguards for protecting the administrator accounts to 
prevent unauthorized changes. To do this, use secure passwords and a standard user account 
for normal operation. Other measures, such as the use of security policies, should be applied 
as needed. 

 

 Note 

To protect LOGO!Soft Comfort and LOGO! Web Editor from any undesired manipulation when 
your PC suffers malicious attacks from the Internet, Siemens strongly recommends you to 
install a whitelist tool on the PC. Then use the tool to manage the software installed on your 
PC. 
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Operating the LOGO! Access Tool 3 
3.1 Prerequisite 
 

 Note 

You can only use LOGO! Access Tool in Local Network with a firewall. 

In current version, LOGO! Access Tool only supports one BM connection.  
 

Before using LOGO! Access Tool, make sure that you meet the following requirements:  

• Install LOGO! Access Tool in Microsoft Excel. 

• Connect your PC to the target LOGO! Base Module. 

• Enable the Web server access through LOGO!Soft Comfort. On how to enable the Web 
server access, refer to LOGO!Soft Comfort Online Help. 

 
  Note 

If you enable the HTTPS access, you need to import LOGO! root certificate in Windows 
before you use LOGO! Access Tool. On how to import LOGO! root certificate, refer to the 
chapter Security -> Installing LOGO! Root Certificate of LOGO! System Manual. 

 

3.2 Install LOGO! Access Tool 
Before starting working with LOGO! Access Tool, you need to install it first. 

1. Copy LOGO!AccessTool.xlam to your computer. 
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2. Start Excel. 

3. On the File menu, point to Options, and then click Add-Ins. 

4. In the Manage box, select Excel Add-ins, and then click Go… button. 

 
5. In the "Add-Ins available" pane, click Browse… button. 

 



Operating the LOGO! Access Tool  
3.2 Install LOGO! Access Tool 

 LOGO! Access Tool Help 

10 Operating Instructions, 08/2024, A5E38597895-AG 

6. Browse to the folder which you save "LOGO! Access Tool" in step one and select the tool. 

 
Result: LOGO! Access Tool is listed in the "Add-Ins available" pane and its check box is 
automatically selected. 

7. Click OK. 
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3.3 LOGO! Access Tool Menu 
After installing LOGO! Access Tool successfully, click the toolbar Add-Ins, and then LOGO! 
Access Tool menu is displayed as follows. 

 
LOGO! Access Tool menu consists of two options: 

• Start/Stop: you can use it to start or stop data synchronization. 

• LOGO! Access Tool: click it and a drop-down menu appears. This drop-down menu 
includes Log In Panel, Configure Panel and About Panel. 

 

3.3.1 Log In Panel 

Procedure 
After installing LOGO! Access Tool, log in according to the following steps: 

1. Click Log In in the drop-down list of LOGO! Access Tool menu. 
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2. Enter IP address and password of your LOGO! Base Module after a Login panel appears, and 
then check the box Run when log in. 

 
 

  Note 

LOGO! Access tool shares the same access control with Web server. 
 

3. Click the Log In button. 

 

Login failure troubleshooting 
If the login goes wrong, a dialog appears to remind you that your login fails. You can refer to 
the following table to troubleshoot the error cause and fix the error through corresponding 
solution.  
 
Error code Possible remedy 
2146232576 
(80131700) 

Install .NET Framework 3.5 on your PC: 
Open Control Panel in your PC → Click Program and Features → Click Turn 
Windows features on or off → Check the box of .NET Framework 3.5.  

No error code Restart your PC. 
Enable macros in the Excel: 
Click File in Excel → Click Options → Click Trust Center → Click Trust Center 
Settings → Click Macro Settings → Select Enable all macros → save settings 
and restart Excel. 
If you fail to login the LOGO! Base Module in HTTPS mode, you need to install the 
latest LOGO! Root certificate on your PC. About how to install the certificate, refer 
to section "Security -> Installing LOGO! Root certificate" in LOGO! System Manual. 
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3.3.2 Configure Panel 
In the configure panel, you can set data synchronization period and history data number 
according to the following steps: 

1. In the drop-down list of LOGO! Access Tool menu, click Configure, and then the configure 
panel is displayed. 

2. In the scroll bar of Synchronization Period, you can select one number depending on your 
need. 

 
  Note 

The synchronization period can be configured as the following numbers: 1,10, 30, 60 
seconds, and the default is 1 second. 

 

 
3. In the scroll bar of History Data Number, you can drag the scroll box from up to down to 

select one number for the history data. 

 
  Note 

The history data number varies from 1 to 100, and the default is 5. 
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4. After selecting the number for synchronization period and history data number, click button 
OK. 

 

3.3.3 About Panel 
About panel shows the version information of LOGO! Access Tool. 

 

3.4 Get LOGO! Variable Value 
 

 Note 

Make sure that you enable Web server access of the target LOGO! Base Module before using 
the LOGO! Access Tool. 

 

After logging in (Page 11) LOGO! Access Tool successfully, you can get LOGO! Variable values 
by inputting "=LOGOVAR("id")" in a cell. Then the real time value of this specific variable is 
displayed in the cell. The variable value updates according to the data synchronization period 
you set in the Configure Panel (Page 13). 
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"id" means the identification for LOGO! variables. It consists of variable type and valid index. 
For one dimensional variables, there is only one index, for example: Q1, AI1, VW0. LOGO! 
also supports multiple dimensional variables which have multiple index, for example: SR1.1. 

 

 Note 

When you input an invalid or unsupported id for LOGO!, LOGO! Access Tool cannot return 
data. The following table shows the variables that can be got with LOGO! Access Tool. 

 

 

Variable  Variable 
Type 

Valid Index  
 

 Remarks Example   Example  

Min   Max 
BM working 
status 

STATUS N/A N/A Offline 
Connecting 
Stop 
Running 
Recovering 
Invalid Status 

=LOGOVAR("STATUS") 

Show the Time TIME N/A N/A The time format is YYYY- 
MM-DD hh:mm:ss  

=LOGOVAR("TIME") 

Flag  M 1 64  =LOGOVAR("M1")  
Analog flags AM 1 64  =LOGOVAR("AM1")  
Digital Outputs  Q 1 20  =LOGOVAR("Q1") 
Analog outputs  AQ 1 8  =LOGOVAR("AQ1")  
Digital Inputs I 1 24  =LOGOVAR("I1")  
Cursor keys  Cur 1 4  =LOGOVAR("CUR1") 
LOGO! TD Func-
tion keys  

F 1 4  =LOGOVAR("F1") 

Shift register 
bits 

SR 1 4 The first dimension ad-
dresses index of SR 

=LOGOVAR("SR1.1") 

1 8 The second dimension 
addresses index of SR 

=LOGOVAR("SR4.8") 

Network inputs  NI 1 64  =LOGOVAR("NI1")  
Analog Inputs  AI 1 8  =LOGOVAR("AI1")  
Network analog 
inputs  

NAI 1 32   =LOGOVAR("NAI1")  



Operating the LOGO! Access Tool  
3.4 Get LOGO! Variable Value 

 LOGO! Access Tool Help 

16 Operating Instructions, 08/2024, A5E38597895-AG 

Variable  Variable 
Type 

Valid Index  
 

 Remarks Example   Example  

Network outputs  NQ 1 64  =LOGOVAR("NQ1")  
Network analog 
outputs 

NAQ 1 16  =LOGOVAR("NAQ1")  

Variable 
Memory (In Bit) 
(LOGO! 8.FS4 
and the later 
version) 

VB 0 850 The first dimension ad-
dresses index of VB 

=LOGOVAR("VB0.0") 
VXB 0 2047 =LOGOVAR("VXB0.0") 
VRB 0 511 =LOGOVAR("VRB0.0") 
VB, VXB, 
VRB 

0 7 The second dimension 
address index of VB 

=LOGOVAR("VB89.7") 

Variable 
Memory (In 
Byte) 

VB 0 850  =LOGOVAR("VB0") 
VXB 0 2047 =LOGOVAR("VXB5") 
VRB 0 511 =LOGOVAR("VRB6") 

Variable 
Memory (In 
Words) 

VW 0 849 The index is counted by 
Byte. It will try to reinter-
pret the byte and its next 
byte as a big-endian word. 

 =LOGOVAR("VW0")  
VXW 0 2046  =LOGOVAR("VXW6")  
VRW 0 510  =LOGOVAR("VRW8")  

Variable 
Memory (In 
Double Words) 

VD 0 847 The index is counted by 
Byte. It will try to reinter-
pret the byte and its next 
3 bytes as a big -endian 
double word. 

=LOGOVAR("VD0") . 
VXD 0 2044  =LOGOVAR("VXD8")  
VRD 0 508  =LOGOVAR("VRD12")  

LOGOVAR combinations 
You can use the following combinations to set the data format by adding them after the 
function LOGOVAR. For example, input "=LOGOVARS("AI")" in a cell, you can get signed value 
for AI. 
 
Format 
letter 

Description Data Log let-
ter 

Description 

S Show signed value L Write the value to data log 
U Show unsigned value 
B Show binary value 
H Show hexadecimal value 
 The default is unsigned 

value 
 The default is that the value is not writ-

ten in data log 

You can use combination L together with S, H or B. For example, when you input 
"=LOGOVARSL("AI1")", you can get a log file with signed value of AI1.  

Whether you input L before or after S/H/B, you get the same output for "=LOGOVARSL("AI1")" 
and "=LOGOVARLS("AI1")". 

Trend direction (TR/TD) 

You can add the argument of trend direction after LOGOVAR combination and this argument 
is optional. "TR" means that history data is shown on the right of the cell where the formula 
"=LOGOVAR("id") is placed. "TD" means the history data is shown on the downside of the cell 
where the formula is placed. For example, LOGOVARS( id, "TR") means the signed value and 
history data is shown on the right of the cell. 
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Generate log files with LOGOVARL 
To generate log files for a variable, input "=LOGOVARL("id")" in a cell. The log file updates 
according to the data synchronization period you set in the Configure Panel (Page 13).  

• Log files are saved as csv files. The file name is composed of three parts: the excel file 
name, IP of the connected BM, and the time stamp. For example, 
Test_192.168.0.1_20160406080001. 

• Log files are saved in the parent folder of the working excel. If you haven't saved the excel 
yet or the parent folder cannot be saved, the log files are saved in the My document folder 
of the Windows active user. 

• If you use LOGOVARL for multiple variables, their log files are saved in different columns 
of one csv file. See an example of log file as follows: 

 
• You can add a suffix (@ serial number) to sort your variables in the log files. For example, 

if you have five variables in your working excel, you input them as LOGOVARL("Flag1@1"), 
LOGOVARL("I1@2"), LOGOVARL("Q1@3"), LOGOVARL("SR2.5@4"), LOGOVARL("F5@5"). 
Then the variables are listed in your log files as Flag1, I1, Q1, SR2.5, F5. The default serial 
number is 0. 
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 Note 
Capacity of LOGO! Access Tool 

A csv file has a maximum of 20000 lines. LOGO! Access Tool will automatically write to a new 
log file when a log file is full.  

You can have up to 500 log files in a folder. When the limitation is reached, your old log files 
will be removed in chronological order. 

LOGO! 8 Standard can only synchronize 72 variables for all supported types.  

LOGO! 8.FS4 and later version can synchronize 75 consecutive VM or 7 discrete VM. LOGO! 
8.FS4 and later version has no limit for the other variables. 

The variables which cannot be synchronized are returned as invalid data. 
 

3.5 Uninstall the LOGO! Access Tool 
Follow the below steps to remove LOGO! Access Tool completely from your computer. 

1. Start Excel. 

2. On the File menu, point to Options, and then click Add-Ins. 

3. In the Manage box, select Excel Add-ins, and then click Go… button. 
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4. In the "Add-Ins available" pane, uncheck the check box next to "LOGO! Accesstool". 

 
5. Click OK. 

6. On the toolbar Add-Ins, right-click LOGO! Access Tool. 

7. Select Delete Custom Command. 

 
8. Delete the source file LOGO! Access Tool from your computer. 
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3.6 Reinstall the LOGO! Access Tool 
LOGO! Access Tool cannot work properly in the following cases. 

• You move LOGO! Access Tool to another location. 

• You update excel to a higher version. 

• You use excel workbook in another computer. 

For the existing workbooks can work properly, follow the below steps to update the tool. 

1. Reinstall LOGO! Access Tool. On how to reload your LOGO! Access Tool, refer to Install 
LOGO! Access Tool (Page 8). 

2. Edit the links in your workbook. 

Edit the links in your workbook 
Update the link to your LOGO! Access Tool according to the following instructions: 

1. On the Data tab, in the Connections group, click Edit Links. 

 
2. Check the status in the Status column. 

 
3. Click Change source... and browse to the folder where LOGO! Access Tool is stored. 
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4. Click the LOGO! Access Tool to update the links. The status of the source changes to "OK". 

 
5. Click Close. 
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